Compilation Errors in latest eclipse, due to Access Restrictions on Java Plugin API

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Compilation Errors in latest eclipse, due to Access Restrictions on Java Plugin API

Sandro Martini
Hi all,
after switching to Java 7 and latest Eclipse 4.3.x for developments
now I have a compilation error when opening Pivot sources in a new
workspace.

This is due to the Access Restrictions on Java Plugin API we use in
wtk/BrowserApplicationContext for example, to be able to let Applets
exchange data with JavaScript in the Browser ... ok, anyway the error
now is due to a default settings (and generally speaking good :-) ) on
Deprecated and restricted API, which is to change from Error to
Warnings or Ignore ... you can find it here:

Window / Preferences / Java / Compiler / Error/Warnings , and then under:
Deprecated and restricted API and then Forbidden reference (access rules) .

this could be a useful info to remember :-) ...


Note that I just updated eclipse projects for 2.0.x maintenance branch
to stay on Java 6, but with a generic Java-SE 6 Profile (and no more
with Eclipse default JRE, that was one of latest Java SE 6) ...

Last, enabling many of eclipse warnings now I get many warnings for
small things (many are mostrly to follow good coding rules), so we'll
try to improve/fix them only in trunk (to avoid too much noise in
2.0.x branch).
Nota that in sources you can find many unnecessary SuppressWarnings
(eclipse say this) but we keep them to not have some noise during our
Ant Builds.


Bye,
Sandro
Loading...